Hash :
d373b4fa
Author :
Thomas de Grivel
Date :
2023-01-21T15:08:37
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93
#!/usr/bin/make -f
#-*- makefile -*-
# Made with the aid of dh_make, by Craig Small
# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
# Some lines taken from debmake, by Christoph Lameter.
SHELL=/bin/bash
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
build: build-stamp
build-stamp:
dh_testdir
./configure --prefix=/usr --mandir='$${prefix}/share/man' \
--infodir='$${prefix}/share/info'
$(MAKE)
touch build-stamp
clean:
test README -nt help2man.PL # maintainer sanity check
dh_testdir
dh_testroot
-$(MAKE) distclean
rm -f build-stamp install-stamp
dh_clean
install: install-stamp
install-stamp: build-stamp
dh_testdir
dh_testroot
dh_clean -k
dh_installdirs
$(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
touch install-stamp
# Build architecture-independent files here.
binary-arch: build install
dh_testdir
dh_testroot
dh_installdocs
dh_installinfo
dh_installexamples
dh_installchangelogs
dh_compress
dh_fixperms
dh_installdeb
dh_perl -V
dh_shlibdeps
dh_gencontrol
dh_md5sums
dh_builddeb
# Build architecture-dependent files here.
binary-indep: build install
# We have nothing to do by default.
source diff:
@echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
# maintainer pre-release setup
AM = COPYING INSTALL install-sh mkinstalldirs
maint-prep:
cp $(addprefix /usr/share/automake/,$(AM)) .
export ver=`./help2man.PL --version`; \
export debver=`perl -ne '/\\(([^)]*)/ and print $$1; exit' debian/changelog`; \
(echo " README for GNU help2man version $$ver"; \
echo; \
echo "help2man is a script to create simple man pages from the --help and"; \
echo "--version output of programs."; \
echo ""; \
echo " http://www.gnu.org/software/help2man/"; \
echo " ftp://ftp.gnu.org/gnu/help2man/help2man-$$debver.tar.gz"; \
echo ""; \
echo "Since most GNU documentation is now in info format, this provides a"; \
echo "way to generate a placeholder man page pointing to that resource while"; \
echo "still providing some useful information."; \
echo ""; \
echo "-- "; \
echo "Brendan O'Dea <bod@debian.org>") >README
ln -sf debian/changelog ChangeLog
autoconf
configure
$(MAKE) all distclean
maint-clean: maint-prep
configure
$(MAKE) maintainer-clean
rm -f README ChangeLog $(AM)
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary maint-prep maint-clean