Hash :
12222434
Author :
Date :
2012-06-22T00:05:54
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91
#!/usr/bin/make -f
# Sample debian/rules that uses debhelper.
# GNU copyright 1997 to 1999 by Joey Hess.
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
CFLAGS = -Wall -g
DTMPDIR = $(CURDIR)/debian/tmp
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
CFLAGS += -O0
else
CFLAGS += -O2
endif
ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
INSTALL_PROGRAM += -s
endif
configure: configure-stamp
configure-stamp:
dh_testdir
QUILT_PATCHES=debian/patches quilt push -a || test $$? = 2
# ./configure --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
touch $@
build: build-stamp
build-stamp: configure-stamp
dh_testdir
# $(MAKE) CFLAGS="$(CFLAGS)"
mkdir -p $(CURDIR)/build-debian
(cd $(CURDIR)/build-debian; cmake -DCMAKE_VERBOSE_MAKEFILE:BOOL=1 -DCMAKE_INSTALL_PREFIX:PATH=/usr -DCMAKE_BUILD_TYPE:STRING=Release ..)
(cd $(CURDIR)/build-debian; $(MAKE) )
touch $@
clean:
dh_testdir
dh_testroot
rm -f build-stamp configure-stamp
rm -rf $(CURDIR)/build-debian
[ ! -f Makefile ] || $(MAKE) distclean
QUILT_PATCHES=debian/patches quilt pop -a -R || test $$? = 2
dh_clean
install: build
dh_testdir
dh_testroot
dh_clean -k
(cd $(CURDIR)/build-debian; $(MAKE) install DESTDIR=$(DTMPDIR) )
# mv debian/tmp/usr/share/doc/ftgl debian/tmp/usr/share/doc/libftgl-dev
dh_install --list-missing --sourcedir=debian/tmp
binary-indep: build install
dh_testdir
dh_testroot
dh_installchangelogs -i ChangeLog
dh_installdocs -i
dh_installexamples -i
dh_compress -i
dh_fixperms -i
dh_installdeb -i
dh_gencontrol -i
dh_md5sums -i
dh_builddeb -i
binary-arch: build install
dh_testdir
dh_testroot
dh_installchangelogs -a ChangeLog
dh_installdocs -a
dh_installexamples -a
# dh_installdebconf -a
# dh_installmenu -a
# dh_installinfo -a
dh_installman -a
# dh_undocumented -a
dh_link -a
dh_strip -a
dh_compress -a
dh_fixperms -a
dh_makeshlibs -p libftgl2 -V 'libftgl2 (>= 2.1.3~rc5)'
dh_installdeb -a
dh_shlibdeps -a
dh_gencontrol -a
dh_md5sums -a
dh_builddeb -a
binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure